This page is for additional resources and recommendations that may help you with your projects. These are references that will help you set up other products that make developing with api.video easier. Please note if you have issues with these tools or products, your best bet for support is to search online for additional resources to do with your issue, or contact the appropriate vendor.

OBS

If you're new to live streaming, OBS is a great tool to start with. Simply download, and then set up with your livestream following our tutorial

Sample Video Files

If you wanted to try out api.video, but you don't have specific videos you want to test with, we recommend these site for samples:

PHP

This section provides tools and suggestions for working with PHP. Content is geared towards Mac users. If you are a PC user and would like to see more content focused on your workstation, please send us feedback using the chat balloon in the lower right corner of the screen, or write us in the community forum.

PHP Development

If you're just going to run a script at the command line on a Mac, you probably already have PHP installed, and that will be sufficient for your project. If you are planning on doing more, this section goes over some of the tools we use to build our code samples. You don't have to use these to try the samples, but you may find these recommendations helpful if you are setting up a PHP environment.

MAMP

If you're doing something where you'll need a local server environment, we recommend MAMP. MAMP does not affect existing installations on your system, everything it uses is self-contained. You can learn more about MAMP here: mamp.info/en/mamp/mac/.

Composer

Many of our PHP projects use Composer as a dependency manager. Composer is not required - you can always manually manage dependencies on your own. Should you choose to work with Composer and MAMP, you may run into the issue of needing Composer to work with MAMP's version of PHP, not your Mac's version of PHP (yes it has its own PHP, everything in MAMP is separate). In which case, please use these instructions to install Composer: Install Composer to use MAMP's PHP.md. Using these instructions will result in a global install of Composer, allowing you to use it successfully with MAMP, or without MAMP should you choose not to work with MAMP.